<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":156,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-83226883-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>MarylandVarsity.rivals.com  -  Top Football Performers </title>
<meta content='MarylandVarsity.rivals.com  -  Top Football Performers ' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-773c5d4ebe26067280b5e850d21a66b26be70f2a7a67fa2d77232bcefca32473.css" />


<script src="https://cdn.rivals.com/production/assets/lib-2c218050dad198426f2e9ad50588b8e7f779d699e9bbbd1fde5e701df92e3866.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-cdb4aa7145e591969e04adce96d50d80803032ce8c63ccc5fa1cf7df2335edf4.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="5pBr3TrMuC0Ts/EB4jcTnDyrUh8ey4N6pFX4oYh2v0Uj21dz1QwXUTA5ceLMkY9z6PEi/mnABCXdmNGT5De5jA==" />
<script>
  (function () {
    'use strict';
  
    angular.module('rivals').factory('userPaths', function () {
      var basePath = "rivals.com";
  
      var siteUrl = function(subdomain) {
        if(subdomain === 'rivals') {
          return window.location.protocol + '//' + basePath;
        } else {
          return window.location.protocol + '//' + subdomain + '.' + basePath;
        }
      };
  
      var trendingThreads = function(baseUrl, forum) {
        return baseUrl + 'api/threads/' + forum + '/trending';
      };
  
      var publishingDashboardUrl = function(subdomain) {
        return siteUrl(subdomain) + '/publishing/contents';
      };
  
      var commitmentsRelativePath = function (page, year) {
        var url;
        if (!page || (page != 'rivals150' && page != 'basketball')) {
          url = "/commitments/football"
        } else {
          url = "/commitments/basketball"
        }
  
        return url + (year ? '/' + year : '');
      };
  
      var commitmentsPath = function (page, year) {
        return basePath + commitmentsRelativePath(page, year);
      };
  
  
      var apiV1RanksProspectsPath = function (rank_id) {
        return "/api/v1/ranks/:rank_id/prospects".replace(/\:rank_id/i, rank_id);
      };
  
      var editContentsPath = function (content_id) {
        return "/publishing/contents/:content_id/edit".replace(/\:content_id/i, content_id);
      };
  
      var apiV1RankPeoplePath = function (rank_id) {
        return "/api/v1/people/rank/:rank_id".replace(/\:rank_id/i, rank_id);
      };
  
      var apiV1ForecastGraphPath = function (prospect_id) {
        return "/api/v1/content/forecast_graph/:prospect_id".replace(/\:prospect_id/i, prospect_id);
      };
  
      return {
        adminHomePath: "/admin/home",
        highschoolApiPath: "/api/v1/content/highschools",
        apiV1BreakingNewsPath: "/api/v1/breaking_news",
        apiV1ContentCollegesPath: "/api/v1/content/colleges",
        apiV1ContentContentsPath: "/api/v1/content/contents",
        apiV1ContentHighschoolsPath: "/api/v1/content/highschools",
        apiV1CustomModules: "/api/v1/custom_modules",
        apiV1CustomModulesPath: "/api/v1/custom_modules/id",
        apiV1EventsPath: "/api/v1/events",
        apiV1FavoriteBlocksPath: "/api/v1/publishing/favorite_blocks",
        apiV1FlipperShowPath: "/api/v1/flipper?key=key",
        apiV1ForecastGraphPath: apiV1ForecastGraphPath,
        apiV1ContentForecastsPath: "/api/v1/content/forecasts",
        apiV1GalleriesPath: "/api/v1/galleries",
        apiV1HpCustomModules: "/api/v1/hp_custom_modules",
        apiV1HpEnrichments: "/api/v1/hp_enrichments",
        apiV1ImagesPath: "/api/v1/images",
        apiV1ProspectRankingsPath: "/api/v1/prospect_rankings",
        apiV1RankPeoplePath: apiV1RankPeoplePath,
        apiV1RanksProspectsPath: apiV1RanksProspectsPath,
        apiV1TrendingContentsPath: "/api/v1/trending_contents",
        apiV1UsersPath: "/api/v1/users",
        basePath: basePath,
        commitmentsPath: commitmentsPath,
        commitmentsRelativePath: commitmentsRelativePath,
        contentsPath: "/news/slug",
        editContentsPath: editContentsPath,
        forumsPath: "https://marylandvarsity.forums.rivals.com/",
        forumsStatisticsPath: "",
        galleriesPath: "/galleries",
        homepagePath: "/content/sport",
        newUserRegistrationPath: "/sign_up",
        newSiteSubscriptionPath: "/subscriptions/new",
        prospectApiPath: "/api/content/prospects",
        prospectCardPath: "/content/prospect_cards/id",
        prospectsPath: "/content/prospects/id",
        publishingDashboardUrl: publishingDashboardUrl,
        registerPath:  "/sign_up",
        rivals250Path: "/prospect_rankings?sport=rivals250",
        signInPath:  "/users/sign_in",
        signOutPath:  "/users/sign_out",
        siteUrl: siteUrl,
        subscribePath: "/users/subscriptions",
        trendingThreads: trendingThreads,
        userProfileEditPath: "/users/profile",
        userProfilePath: "/users/profile"
      };
    });
  }).call(this);
</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://marylandvarsity.rivals.com/news/top-football-performers-128' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/s1vesbkpssibskkbzqda' property='og:image'>
<meta content='Maryland Varsity takes a look at the top individual performers last night on the gridiron. See who made the cut now!' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-09-01 07:07:44 -0500' property='article:published_time'>
<meta content='2018-09-01 07:07:45 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "marylandvarsity.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='marylandvarsity contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .marylandvarsity #programming > h1 {
      background-color: #000000 !important; } }
  .marylandvarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  .marylandvarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .marylandvarsity > header .wrapper-container {
        border-bottom: 5px solid #ffb500 !important; } }
  .marylandvarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .marylandvarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .marylandvarsity > header .invalid-email-banner a:hover {
      color: #ffb500; }
  @media screen and (max-width: 767px) {
    .marylandvarsity > header .mobile-header {
      background-color: #ffb500 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .marylandvarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .marylandvarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .marylandvarsity > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .marylandvarsity > header .nav-row > ul,
    .marylandvarsity > header .third-nav {
      background-color: white !important; }
    .marylandvarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .marylandvarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #ffb500; }
  
  .site-secondary-background-color {
    background-color: #ffb500; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #ffb500; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Maryland HS Sports" class="school-header" href="https://marylandvarsity.rivals.com/"><span class='header-text'>
        MarylandVarsity.rivals.com
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://marylandvarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;marylandvarsity&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://marylandvarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;marylandvarsity&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 1197798924,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Top Football Performers "
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Top Football Performers ' name='twitter:title'>
<meta content='Maryland Varsity takes a look at the top individual performers last night on the gridiron. See who made the cut now!' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/s1vesbkpssibskkbzqda' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":73,"legacy_id":1002,"name":"MarylandVarsity.rivals.com","friendly_name":"Maryland HS Sports","annual_discount":null,"subdomain":"marylandvarsity","primary_color":"000000","secondary_color":"ffb500","font_color":"ffffff","short_name":"marylandvarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-83226883-1"}, true, 95, nil, {"id":26,"primary_color":"000000","secondary_color":"ffb500","font_color":"ffffff","commitment_module_football":false,"rivals_module_football":false,"header_name":null,"header_logo_cloudinary":null,"mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-83226883-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":73,"created_at":"2016-11-23T13:38:41.836-06:00","updated_at":"2018-06-04T12:52:42.219-05:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://marylandvarsity.forums.rivals.com","scoreboard_scores_id":15125,"scoreboard_photos_id":15126,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://marylandvarsity.rivals.com/news/top-football-performers-128' background-color='#000000' base-api-url='https://marylandvarsity.forums.rivals.com/' homepage='false' message-board-url='https://marylandvarsity.forums.rivals.com' pub-ad='null' size='size' space-id='1197798924' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://marylandvarsity.rivals.com/news/top-football-performers-128/printable' site-name='MarylandVarsity.rivals.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-09-01 07:07:44 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1954268/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Top Football Performers </h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Lucas Feddersen
&bull;
</span>
<span class='type-sm'>MarylandVarsity.rivals.com</span>
<div class='type-sm'>
<a href='//twitter.com/MarylandVarsity' target='_blank'>@MarylandVarsity</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/MarylandVarsity'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>Maryland Varsity takes a look at the top individual performers last night on the gridiron. See who made the cut now!</p><p>Henry Rentz Severn School 71 yards and caught five passes for 77 yards </p><p><a href="https://marylandvarsity.forums.rivals.com/threads/top-football-performers-8-30-8-31-9-1.6308/">SUBSCRIBERS: See the full list here now!</a></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://static.hudl.com/users/prod/9805400_d5f9a89ec6f94262a146862e93707a96.jpg' target='_blank'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/s1vesbkpssibskkbzqda)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/s1vesbkpssibskkbzqda" alt="S1vesbkpssibskkbzqda" />
</a>
</div>
<figcaption class='image-caption'>Hudl</figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>What other coverage am I missing by not subscribing?<br></p><p> In-Season Coverage</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> Private School Breakdown</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> 4A Breakdown</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> 3A Breakdown</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> 2A Breakdown</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> 1A Breakdown</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> Top 25 Teams</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> Game Quotes</a> - 9/3</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> Top Performers</a> - 9/8</p><p> <a href="https://marylandvarsity.forums.rivals.com/forums/maryland-varsity-insider-board.10/"> Games to Watch</a> - 9/9</p><p> 2018 Preseason Honors</p><p> <a href="https://marylandvarsity.rivals.com/news/2018-senior-of-the-year-nominees">Senior of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-junior-of-the-year-nominees">Junior of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-sophomore-of-the-year-nominees">Sophomore of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-quarterback-of-the-year-nominees">Quarterback of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-running-back-of-the-year-nominees">Running Back of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-wide-receiver-of-the-year-nominees">Wide Receiver of the Year Nominees</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-linebacker-of-the-year-nominees">Linebacker of the Year Nominees</a></p><p> 2018 Full Conference Previews</p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-upper-chesapeake-bay-susquehanna-1">Upper Chesapeake Bay - Susquehanna</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-washington-county-1">Washington County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-upper-chesapeake-bay-chesapeake-1">Upper Chesapeake Bay - Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-southern-maryland-potomac-1">Southern Maryland - Potomac</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-prince-george-s-county-4a-1">Prince George's County 4A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-southern-maryland-chesapeake-1">Southern Maryland Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-montgomery-county-4a-south-conference-1">Montgomery County 4A - South</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-prince-george-s-county-3a-2a-1a-conference-1">Prince George's County 3A/2A/1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-montgomery-county-2a-3a-conference-1">Montgomery County 2A/3A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-montgomery-county-4a-east-conference-1">Montgomery County 4A - East</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-miaa-b-conference-1">MIAA B</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-miaa-c-conference-1">MIAA C</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-central-maryland-conference-1">Central Maryland</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-howard-county-conference-1">Howard County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-interstate-conference-1">Interstate</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-bayside-3a-2a-conference-1">Bayside 3A/2A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-bayside-1a-conference-1">Bayside 1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-washington-catholic-conference-1">Washington Catholic</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-carroll-county-conference-1">Carroll County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-miaa-a-conference-1">MIAA A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-baltimore-county-iii-conference-1">Baltimore County III</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-baltimore-county-i-conference-1">Baltimore County I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-baltimore-county-ii-conference-1">Baltimore County II</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-anne-arundel-county-conference-1">Anne Arundel County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-baltimore-city-i-conference-1">Baltimore City I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preview-baltimore-city-ii-conference-1">Baltimore City II</a></p><p> Preseason All State Teams</p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-4a-preseason-all-state-offense">4A Offense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-3a-preseason-all-state-offense">3A Offense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-private-school-preseason-all-state-offense-2">Elite Offense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-elite-preseason-all-state-offense-2">Elite Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-2a-preseason-all-state-offense">2A Offense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-1a-preseason-all-state-defense">1A Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-1a-preseason-all-state-offense">1A Offense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-private-school-preseason-all-state-defense-2">Private School Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-4a-preseason-all-state-defense">4A Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-3a-preseason-all-state-defense">3A Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-elite-preseason-all-state-defense-3">Elite Defense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/first-team-2a-preseason-all-state-defense">2A Defense - 1st Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-elite-preseason-all-state-offense-5">Elite Offense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/third-team-elite-preseason-all-state-offense-2">Elite Offense - 3rd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/third-team-elite-preseason-all-state-defense-3">Elite Defense - 3rd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/fourth-team-elite-preseason-all-state-defense-2">Elite Defense- 4th Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/fourth-team-elite-preseason-all-state-offense-3">Elite Offense - 4th Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-2a-preseason-all-state-defense">2A Defense- 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-1a-preseason-all-state-offense">1A Offense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-1a-preseason-all-state-defense">1A Defense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-2a-preseason-all-state-offense">2A Offense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-private-school-preseason-all-state-offense-3">Private Offense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-private-school-preseason-all-state-defense-3">Private Defense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-class-4a-preseason-all-state-defense-1">4A Defense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-class-3a-preseason-all-state-offense-1">3A Offense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-class-3a-preseason-all-state-defense-2">3A Defense - 2nd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/third-team-private-school-preseason-all-state-defense-3">Private Defense - 3rd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/third-team-private-school-preseason-all-state-offense-3">Private Offense - 3rd Team</a></p><p> <a href="https://marylandvarsity.rivals.com/news/second-team-class-4a-preseason-all-state-offense-2">4A Offense - 2nd Team</a></p><p> Top Sophomores (Class of 2021)</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-quarterbacks-in-2021-3">Top Quarterbacks</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-running-backs-in-2021-2">Top Running Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-wide-receivers-in-2021-2">Top Wide Receivers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-offensive-linemen-in-2021-3">Top Offensive Linemen</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-ends-in-2021-5">Top Defensive Ends</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-linebackers-in-2021-2">Top Linebackers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-backs-in-2021-2">Top Defensive Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/class-of-2021-top-football-prospect-database-6">Top Database</a></p><p>Top 10 Candidates in 2019</p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p1-1">Part One</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p2-1">Part Two</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p3-1"> Part Three</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p4-1">Part Four</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p5-1">Part Five</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p6-1">Part Six</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2019-p7-1">Part Seven</a></p><p> Top Seniors (Class of 2019)</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-quarterbacks-in-2019-15">Top Quarterbacks</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-running-backs-in-2019-15">Top Running Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-fullbacks-in-2019-4">Top Fullbacks</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-wide-receivers-in-2019-15">Top Wide Receivers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-tight-ends-in-2019-10">Top Tight Ends</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-offensive-guards-in-2019-5">Top Offensive Guards</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-offensive-tackles-in-2019-5">Top Offensive Tackles</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-ends-in-2019-11">Top Defensive Ends</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-tackles-in-2019-10">Top Defensive Tackles</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-linebackers-in-2019-14">Top Linebackers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-safeties-in-2019-1">Top Safeties</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-backs-in-2019-15">Top Defensive Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-kickers-in-2019-9">Top Kickers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-punters-in-2019-9">Top Punters</a></p><p>Top Juniors (Class of 2020)</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-quarterbacks-in-2020-9">Top Quarterbacks</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-running-backs-in-2020-10">Top Running Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-wide-receivers-in-2020-10">Top Wide Receivers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-tight-ends-in-2020-5">Top Tight Ends</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-offensive-tackles-in-2020-3">Top Offensive Tackles</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-offensive-guards-in-2020-3">Top Offensive Guards</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-tackles-in-2020-5">Top Defensive Tackles</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-ends-in-2020-5">Top Defensive Ends</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-linebackers-in-2020-10">Top Linebackers</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-defensive-backs-in-2020-10">Top Defensive Backs</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-safeties-in-2020-3">Top Safeties</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-top-kickers-in-2020-5">Top Kickers</a></p><p> Early Conference Previews</p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-washington-catholic-football-preview-1">Washington Catholic</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-washington-county-football-preview-1">Washington County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-upper-chesapeake-bay-susquehanna-football-preview-1">Upper Ches Bay Susquehanna</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-upper-chesapeake-bay-chesapeake-football-preview-1">Upper Ches Bay Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-prince-george-s-county-3a-2a-1a-football-preview-1">Prince George's County 3A/2A/1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-prince-george-s-county-4a-football-preview-1">Prince George's County 4A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-southern-maryland-chesapeake-football-preview-1">Southern Maryland Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-southern-maryland-potomac-football-preview-1">Southern Maryland Potomac</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-montgomery-county-2a-3a-football-preview-1">Montgomery County 2A/3A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-montgomery-county-4a-east-football-preview-1">Montgomery County 4A East</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-montgomery-county-4a-south-football-preview-1">Montgomery County 4A South</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-miaa-b-football-preview-1">MIAA B</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-miaa-c-football-preview-1">MIAA C</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-central-maryland-football-preview-1">Central Maryland</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-howard-county-football-preview-1">Howard County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-interstate-football-preview-1">Interstate</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-miaa-a-football-preview-1">MIAA A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-baltimore-county-iii-football-preview-1">Baltimore County III</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-bayside-3a-2a-football-preview-1">Bayside 3A/2A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-bayside-1a-football-preview-1">Bayside 1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-carroll-county-football-preview-1">Carroll County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-annue-arundel-football-preview">Anne Arundel County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-baltimore-city-i-football-preview-1">Baltimore City I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-baltimore-city-ii-football-preview-1">Baltimore City II</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-baltimore-county-i-football-preview-1">Baltimore County I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/early-2018-baltimore-county-ii-football-preview-1">Baltimore County II</a></p><p> Top Recruited WCAC Players</p><p> <a href="https://marylandvarsity.rivals.com/news/wcac-s-most-recruited-athletes-players-1-5-5">Players 1-5</a></p><p> <a href="https://marylandvarsity.rivals.com/news/wcac-s-most-recruited-athletes-players-6-10-5">Players 6-10</a></p><p> <a href="https://marylandvarsity.rivals.com/news/wcac-s-most-recruited-athletes-players-11-15-4">Players 11-15</a></p><p> <a href="https://marylandvarsity.rivals.com/news/wcac-s-most-recruited-athletes-players-16-20-4">Players 16-20</a></p><p> <a href="https://marylandvarsity.rivals.com/news/wcac-s-most-recruited-athletes-players-21-25-2">Players 21-25</a></p><p> Top Returning Offensive Players</p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-southern-maryland-chesapeake-2">Southern Maryland Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-southern-maryland-potomac-2">Southern Maryland Potomac</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-upper-chesapeake-bay-chesapeake-1">Upper Chesapeake Bay Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-upper-chesapeake-bay-susquehanna-2">Upper Chesapeake Bay Susquehanna</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-washington-catholic-2">Washington Catholic</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-washington-county-2">Washington County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-miaa-a-3">MIAA A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-montgomery-county-2a-3a-3">Montgomery County 2A/3A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-montgomery-county-4a-east-2">Montgomery County 4A - East</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-montgomery-county-4a-south-2">Montgomery County 4A - South</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-prince-george-s-county-3a-2a-1a-2">Prince George's County 3A/2A/1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-prince-george-s-county-4a-2">Prince George's County 4A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-carroll-county-2">Carroll County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-central-maryland-2">Central Maryland</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-interstate-3">Interstate</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-howard-county-2">Howard County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-miaa-b-2">MIAA B</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-miaa-c-2">MIAA C</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-baltimore-county-iii-1">Baltimore County III</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-bayside-3a-2a-4">Bayside 3A/2A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-bayside-1a-2">Bayside 1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-anne-arundel-county-3">Anne Arundel County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-baltimore-city-i-6">Baltimore City I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-baltimore-city-ii-2">Baltimore City II</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-baltimore-county-i-2">Baltimore County I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-offensive-football-players-baltimore-county-ii-1">Baltimore County II</a></p><p> Top Returning Defensive Players</p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-southern-maryland-chesapeake-2">Southern Maryland Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-southern-maryland-potomac-2">Southern Maryland Potomac</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-upper-chesapeake-bay-chesapeak-2">Upper Chesapeake Bay Chesapeake</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-upper-chesapeake-bay-susquehanna-2">Upper Chesapeake Bay Susquehanna</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-washington-catholic-2">Washington Catholic</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-washington-county-2">Washington County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-miaa-a-2">MIAA A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-montgomery-county-2a-3a-2">Montgomery County 2A/3A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-montgomery-county-4a-east-2">Montgomery County 4A - East</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-montgomery-county-4a-south-2">Montgomery County 4A - South</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-prince-george-s-county-3a-2a-1a-2">Prince George's County 3A/2A/1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-prince-george-s-county-4a-2">Prince George's County 4A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-carroll-county-2">Carroll County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-central-maryland-2">Central Maryland</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-interstate-2">Interstate</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-howard-county-2">Howard County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-miaa-b-2">MIAA B</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-miaa-c-2">MIAA C</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-baltimore-county-iii-1">Baltimore County III</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-bayside-3a-2a-2">Bayside 3A/2A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-bayside-1a-2">Bayside 1A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-anne-arundel-county-2">Anne Arundel County</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-baltimore-city-i-5">Baltimore City I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-baltimore-city-ii-2">Baltimore City II</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-baltimore-county-i-2">Baltimore County I</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-returning-defensive-football-players-baltimore-county-ii-1">Baltimore County II</a></p><p> Top Recruited MIAA Players</p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-1-5-3">Players 1-5</a></p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-6-10-3">Players 6-10</a></p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-11-15-3">Players 11-15</a></p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-16-20-3">Players 16-20</a></p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-21-25-3">Players 21-25</a></p><p> <a href="https://marylandvarsity.rivals.com/news/miaa-s-most-recruited-athletes-players-26-30-1">Players 26-30</a></p><p>Top 10 Candidates in 2020</p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p1">Part One</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p2">Part Two</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p3">Part Three</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p4">Part Four</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p5">Part Five</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p6">Part Six</a></p><p> <a href="https://marylandvarsity.rivals.com/news/top-10-football-candidates-in-2020-p7">Part Seven</a></p><p> Top Player Databases</p><p> <a href="https://marylandvarsity.rivals.com/news/class-of-2018-football-top-prospect-database-12">Class of 2018</a></p><p> <a href="https://marylandvarsity.rivals.com/news/class-of-2019-football-top-prospect-database-15">Class of 2019</a></p><p> <a href="https://marylandvarsity.rivals.com/news/class-of-2020-football-top-prospect-database-9">Class of 2020</a></p><p>2017 Postseason Honors</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-quarterback-of-the-year-1">Junior Quarterback of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-running-back-of-the-year">Junior Running Back of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-wide-receiver-of-the-year">Junior Wide Receiver of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-offensive-lineman-of-the-year">Junior Offensive Linemen of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-linebacker-of-the-year">Junior Linebacker of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-junior-defensive-back-of-the-year">Junior Defensive Back of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-running-back-of-the-year-1">Running Back of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-wide-receiver-of-the-year-1">Wide Receiver of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-offensive-lineman-of-the-year-1">Offensive Lineman of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-defensive-lineman-of-the-year-1">Defensive Lineman of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-quarterback-of-the-year-1">Quarterback of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-linebacker-of-the-year-1">Linebacker of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-defensive-back-of-the-year-1">Defensive Back of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-kicker-of-the-year-1">Kicker of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-senior-of-the-year-1">Senior of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-junior-of-the-year-1">Junior of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-sophomore-of-the-year-1">Sophomore of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-freshman-of-the-year-1">Freshman of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-coach-of-the-year-1">Coach of the Year</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-varsity-s-2017-player-of-the-year-1">Player of the Year</a></p><p>2018 Preseason Rankings</p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preseason-private-school-top-10-v-2-0-1">Private Schools</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preseason-class-4a-top-10-v-2-0-1">Class 4A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preseason-class-3a-top-10-v-2-0-1">Class 3A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preseason-class-2a-top-10-v-2-0-1">Class 2A</a></p><p> <a href="https://marylandvarsity.rivals.com/news/2018-preseason-class-1a-top-10-v-2-0-1">Class 1A</a></p><p> Top Most Recruited Players in 2020</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2020-players-1-5">Rankings 1-5</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2020-players-6-10">Rankings 6-10</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2020-players-11-15">Rankings 11-15</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2020-players-16-20">Rankings 16-20</a></p><p> Top Most Recruited Players in 2019</p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-1-5">Rankings 1-5</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-6-10">Rankings 6-10</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-11-15">Rankings 11-15</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-16-20">Rankings 16-20</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-21-25">Rankings 21-25</a></p><p> <a href="https://marylandvarsity.rivals.com/news/maryland-s-most-recruited-in-2019-players-26-30">Rankings 26-30</a></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://marylandvarsity.rivals.com/news/top-football-performers-128/printable' site-name='MarylandVarsity.rivals.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' scoreboard-photos-id='15126' scoreboard-scores-id='15125' site='{"id":73,"legacy_id":1002,"name":"MarylandVarsity.rivals.com","friendly_name":"Maryland HS Sports","annual_discount":null,"subdomain":"marylandvarsity","primary_color":"000000","secondary_color":"ffb500","font_color":"ffffff","short_name":"marylandvarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-83226883-1"}' twitter-feed='{"id":73,"site_id":73,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:04.828-06:00","updated_at":"2016-02-01T12:25:04.828-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://marylandvarsity.rivals.com/news/top-football-performers-128/printable' site-name='MarylandVarsity.rivals.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('1197798924', 'https://marylandvarsity.rivals.com/news/top-football-performers-128');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Top Football Performers ";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://marylandvarsity.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "1197798924",
    c7: "https://marylandvarsity.rivals.com/news/top-football-performers-128"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fmarylandvarsity.rivals.com%2Fnews%2Ftop-football-performers-128&c5=1197798924&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
